Postresql will not install on Mac OS Catalina

Highlighted
Adventurer

Postresql will not install on Mac OS Catalina

I am getting this error message when trying to download postgresql, any help would be appreciated! 

“postgresql-9.6.15-2-osx” can’t be opened because Apple cannot check it for malicious software." 

I attempted to download the newest version of postgresql but the same message appears. Is there anyway to override this?

Thank you!

*Fixed it, found the override in the system preferences.* 

Archived Discussions


Effective March 31st, we will no longer engage on PostgresRocks.


How to engage with us further?


  • Thought Leadership: EDB Blogs

  • Tips and Tricks: Postgres Tutorials

  • Customer Support: Create a Case Please note: Only customers with an active EDB support subscription and support portal authorization can create support ticket

  • Engage on Stackoverflow While engaging on Stackoverflow tag the question with EDB or EnterpriseDB.

6 REPLIES 6
Highlighted
EDB Team Member

Re: Postresql will not install on Mac OS Catalina

Hi MCDNSQL,

 

Sorry for the inconvenience.

Currently, we are evaluating the newest Apple OS version for compatibility with our internal software/applications and cannot provide further guidance on this OS version until our evaluations are completed. We will update this thread once testing/evaluations are completed.

Regards,
Dhananjay
Highlighted
Adventurer

Re: Postresql will not install on Mac OS Catalina

ETA ?

 

Postgres has a repeating, disappearing popup issue after Catalina install. I had to delete postgres to be able to work. Go to re-install and find out your software is not ready.

 

This is terrible.

 

Highlighted
Level 3 Traveller

Re: Postresql will not install on Mac OS Catalina

The most narcissistic answer in the history of forums is someone saying "Figured it out" thanks! Thanks for doing absolutely nothing to help anyone else. 

Highlighted
Adventurer

Re: Postresql will not install on Mac OS Catalina

Figured it was too obvious of a solution. I simply just went into my System Preferences > Security and Privacy > and unlocked to allow apps to be donwloaded from a foreign source. 

Highlighted
Adventurer

Re: Postresql will not install on Mac OS Catalina

Install on macOS Catalina does not work.

 

Install Error

 

Highlighted
Adventurer

Re: Postresql will not install on Mac OS Catalina

2019/11/05: I downloaded again and this time the install worked. PG was started OK.

 

Stackbuilder won't run, it dies (no message, just disappears) after macOS asks for permission to make changes.

 

© 2019 EnterpriseDB Corporation. All rights reserved.   |   Privacy Policy   |  Terms of Use   |   Trademarks