cancel
Showing results for 
Search instead for 
Did you mean: 

Online Backup Issue

SOLVED
Level 2 Adventurer

Online Backup Issue


While taking backup, after I execute start_backup command the backup file should be created in the data diecrtory. In my case it is not getting created. is it getting created somewhere else, if yes how can I find that.

1 ACCEPTED SOLUTION

Accepted Solutions
EDB Team Member

Re: Online Backup Issue

Hi esamuel,

 

The steps you shared with us are correct , can you share the commands you are using with its outputs.

 

Also, if you can check the data_directory and port using show command at session level are same on which you are executing the backup start stop commands and performing rsync.

 

 

View solution in original post

4 REPLIES 4
EDB Team Member

Re: Online Backup Issue

Hi esamuel,

 

After you execute pg_start_backup('label') command and if it executes successfully then the backup_label file is created in the data_directory. It will disappear after you execute pg_stop_backup(). However, if you use pg_basebackup then the backup _label file is created in the backup directory and not in the current data_directory.

 

Let us know what steps are you following for taking backup.

Level 2 Adventurer

Re: Online Backup Issue

Yes my start backup command is executing properly.   

 

The steps are : 1. Start backup

2. rsync the contents of data directory to backup location follwed by compression.

3. execute stop command.

 

All the commands execute without any issue. Still I cannot recover backup it does not have backup file and the recovery says novalid  bakup file present.

EDB Team Member

Re: Online Backup Issue

Hi esamuel,

 

The steps you shared with us are correct , can you share the commands you are using with its outputs.

 

Also, if you can check the data_directory and port using show command at session level are same on which you are executing the backup start stop commands and performing rsync.

 

 

View solution in original post

Highlighted
Level 2 Adventurer

Re: Online Backup Issue

Got it. There was a default data directory running and default connections as well.

Thanks a ton.