cancel
Showing results for 
Search instead for 
Did you mean: 

EnterpriseDB Technical Alert for Ark v2.0-v3.2 #20190417.01

Technical Alert/Update Information

Technical Alert Name
EDB Technical Alert for Ark v2.0-v3.2 #20190417.01
Product Type
EDB Postgres Ark
Severity
Critical
Release Date
4/25/2019
Technical Alert Details
Technical Alert
RECOMMENDED ACTIONS
Status: Critical
Recommended:  
Recent changes to the community PostgreSQL Yum repository require configuration changes in Ark.  Without these changes, you may not be able to deploy new PostgreSQL clusters in Ark.  More importantly, running clusters may not be fully protected from a failover event.  EDB has fixed this issue in the upcoming Ark 3.3 release and worked with the community to place temporary measures in the Yum repository to mitigate these issues, but it is critical that you update your Ark configuration as soon as possible as described below.
 
Please make the following changes to your DB Engine configurations (found on the “Admin” tab of the Ark console) - replace the existing “yum.postgresql.org” repo rpm URL with the correct URL as shown below:
 
Postgres 9.4 engines on CentOS 6:
            https://yum.postgresql.org/9.4/redhat/rhel-6-x86_64/pgdg-redhat-repo-latest.noarch.rpm
 
Postgres 9.4 engines on CentOS / RHEL 7:
            https://yum.postgresql.org/9.4/redhat/rhel-7-x86_64/pgdg-redhat-repo-latest.noarch.rpm
 
Postgres 9.5 engines on CentOS 6:
            https://yum.postgresql.org/9.5/redhat/rhel-6-x86_64/pgdg-redhat-repo-latest.noarch.rpm
 
Postgres 9.5 engines on CentOS / RHEL 7:
            https://yum.postgresql.org/9.5/redhat/rhel-7-x86_64/pgdg-redhat-repo-latest.noarch.rpm
 
Postgres 9.6 engines on CentOS 6:
            https://yum.postgresql.org/9.6/redhat/rhel-6-x86_64/pgdg-redhat-repo-latest.noarch.rpm
 
Postgres 9.6 engines on CentOS / RHEL 7:
            https://yum.postgresql.org/9.6/redhat/rhel-7-x86_64/pgdg-redhat-repo-latest.noarch.rpm
 
Postgres 10 engines on CentOS 6:
            https://yum.postgresql.org/10/redhat/rhel-6-x86_64/pgdg-redhat-repo-latest.noarch.rpm
 
Postgres 10 engines on CentOS / RHEL 7:
            https://yum.postgresql.org/10/redhat/rhel-7-x86_64/pgdg-redhat-repo-latest.noarch.rpm
 
Postgres 11 engines on CentOS 6:
            https://yum.postgresql.org/11/redhat/rhel-6-x86_64/pgdg-redhat-repo-latest.noarch.rpm
 
Postgres 11 engines on CentOS / RHEL 7:
            https://yum.postgresql.org/11/redhat/rhel-7-x86_64/pgdg-redhat-repo-latest.noarch.rpm
 
Example:
 
The correct DB Engine configuration for Postgres 11 on CentOS / RHEL 7 should contain the following repo URLs:
 
https://USERNAME:PASSWORD@yum.enterprisedb.com/dependencies/redhat/rhel-\$releasever-\$basearch
https://USERNAME:PASSWORD@yum.enterprisedb.com/tools/redhat/rhel-\$releasever-\$basearch
https://yum.postgresql.org/11/redhat/rhel-7-x86_64/pgdg-redhat-repo-latest.noarch.rpm
 
IS THIS ALERT FOR ME?
This alert is for customers using:
  • EDB Ark v2.0 -
TROUBLESHOOTING
If you experience any problems applying the upgrade or restoring the old version after applying the upgrade, please contact Technical Support at:

Email: support@enterprisedb.com
US: +1-732-331-1320 or 1-800-235-5891
UK: +44-2033719820
Brazil: +55-2139581371
India: +91-20-66449612
Version history
Revision #:
1 of 1
Last update:
‎04-25-2019 10:32 AM
Updated by:
 
Labels (1)
Contributors