cancel
Showing results for 
Search instead for 
Did you mean: 

xdb No suitable driver found for jdbc:oracle:thin ERROR

SOLVED
Highlighted
Gold Adventurer

xdb No suitable driver found for jdbc:oracle:thin ERROR

I try to use XDB replication tool to replicate ORACLE to postgres EDB, and i copy the JDBC driver ojdbc5.jar to JAVA_HOME(/usr/lib/jvm/jre/lib/ext) and to XDB_HOME(/opt/PostgreSQL/EnterpriseDB-xDBReplicationServer/lib/jdbc)

when i try to connect i get this ERROR:

 

Database connection information test failed.
No suitable driver found for jdbcSmiley Surprisedracle:thin:@//myIP:1521/myname

error.jpg

 

 

 

I'm missing something?

any idea

regards

1 ACCEPTED SOLUTION

Accepted Solutions
Gold Adventurer

Re: xdb No suitable driver found for jdbc:oracle:thin ERROR

i copy others jdbc

ojdbc6.jar

ojdbc7.jar

ojdbc5.jar

ojdbc14.jar

 

and work

 

thanks

3 REPLIES 3
EDB Team Member

Re: xdb No suitable driver found for jdbc:oracle:thin ERROR

Hi asotolongo,

 

Hope you are doing good..

 

Could you please share the output of ls -ltr command , from your JAVA_HOME (/usr/lib/jvm/jre/lib/ext) and XDB_HOME (/opt/PostgreSQL/EnterpriseDB-xDBReplicationServer/lib/jdbc) location.
Is your publication and subscription server running on same server ?
You can refer to the below link for more information regarding this.
https://www.enterprisedb.com/docs/en/6.0/repguide/EDB_Postgres_Replication_Server_Users_Guide.1.24.h...

 

Thanks ,

Swagata 

Gold Adventurer

Re: xdb No suitable driver found for jdbc:oracle:thin ERROR

HI Swagata,thanks for your answer, 

i readed the documentation refered 

https://www.enterprisedb.com/docs/en/6.0/repguide/EDB_Postgres_Replication_Server_Users_Guide.1.24.h...

 

is your publication and subscription server running on same server ?- YES

 

ls -ltr /usr/lib/jvm/jre/lib/ext

pantalla1_lrt.png

 

ls -lrt /opt/PostgreSQL/EnterpriseDB-xDBReplicationServer/lib/jdbc

 

pantalla2_lrt.png

 

With SQL server function fine!!!

 

i use CENTOS 7

Regards

 

Gold Adventurer

Re: xdb No suitable driver found for jdbc:oracle:thin ERROR

i copy others jdbc

ojdbc6.jar

ojdbc7.jar

ojdbc5.jar

ojdbc14.jar

 

and work

 

thanks