cancel
Showing results for 
Search instead for 
Did you mean: 

PostgreSQL installation issues on CENTOS 7.5

Level 3 Traveller

PostgreSQL installation issues on CENTOS 7.5

I've downloaded the PostgreSQL installer from you website for the Linux.  I'm running Linux CENTOS 7.5 when try to execute the installer I get the following messages below:

[louis@Lenovo-P50 PostgreSQL-10.5.2]$ ./postgresql-10.5-2-linux-x64.run
bash: ./postgresql-10.5-2-linux-x64.run: Permission denied
[louis@Lenovo-P50 PostgreSQL-10.5.2]$ sudo ./postgresql-10.5-2-linux-x64.run
[sudo] password for louis:
sudo: ./postgresql-10.5-2-linux-x64.run: command not found
[louis@Lenovo-P50 PostgreSQL-10.5.2]$ sh ./postgresql-10.5-2-linux-x64.run
./postgresql-10.5-2-linux-x64.run: ./postgresql-10.5-2-linux-x64.run: cannot execute binary file
[louis@Lenovo-P50 PostgreSQL-10.5.2]$ sh postgresql-10.5-2-linux-x64.run
postgresql-10.5-2-linux-x64.run: postgresql-10.5-2-linux-x64.run: cannot execute binary file

 

I've ha no luck getting it to execute, so what could or I'm doing wrong.  I'm new to Linux and PostgreSQL, trying to move from Microsoft i just can't afford it any more. 

 

Thanks

 

 

 

2 REPLIES
EDB Team Member

Re: PostgreSQL installation issues on CENTOS 7.5

 

 

Hi longshoreman,

 

I have tried to reproduce your issue in my local environment and it seems that you have permission issue on the installer file.

Kindly use below command to set the proper permission.

 

chmod +x postgresql-10.5-2-linux-x64.run

sudo ./postgresql-10.5-2-linux-x64.run

 

Hope this helps.

 

Regards,

Dhananjay

EDB Team Member

Re: PostgreSQL installation issues on CENTOS 7.5

Hi  longshoreman,

 

Whenever you try to install any version of postgres, as a mandatory first you need to provide the execute permission then only it allows you to execute the downloaded postgres binary binary file. 

 

Postgres installation should be run through root user.