PEM 7.12 RPM installation Failed due to dependencies.

Highlighted
Silver Adventurer

PEM 7.12 RPM installation Failed due to dependencies.

Hi Support,

        AS per comany policy ,restricted the server internet access not allow to other sites.

we have satelite server,all the RPM's only in that server only.Unix not pushing any software from other side.

Currently we tired PEM7.12 Rpm installation ,it failed.

we tried local repositories also,the one also.

we manually download the dpendencies RPm it's asking all the RPM's,we cannot go the next leavel.

 

I have attached the logs,what we did.

Please Advice how to do this one or send the dependent RPM's.

 

Thanks.

 

FYI,

1.first we tried.

[root@SGATRPRDOTH04 PEM]# cp /home/sgardba/* /PEM
cp: overwrite ‘/PEM/edb-pem-7.12.0-2.rhel7.x86_64.rpm’? y
cp: overwrite ‘/PEM/edb-pem-agent-7.12.0-2.rhel7.x86_64.rpm’? y
[root@SGATRPRDOTH04 PEM]#
[root@SGATRPRDOTH04 PEM]#
[root@SGATRPRDOTH04 PEM]#
[root@SGATRPRDOTH04 PEM]# ll
total 141128
-rwxr-xr-x. 1 root root 16365 Jan 3 09:36 boost-atomic-1.69.0-13.fc32.aarch64.rpm
-rwxr-xr-x. 1 root root 45352 Jan 3 09:36 boost-chrono-1.53.0-27.el7.x86_64.rpm
-rwxr-xr-x. 1 root root 69596 Jan 3 09:36 boost-filesystem-1.53.0-27.el7.x86_64.rpm
-rwxr-xr-x. 1 root root 62432 Jan 3 09:36 boost-iostreams-1.53.0-27.el7.x86_64.rpm
-rwxr-xr-x. 1 root root 151334 Jan 3 09:36 boost-program-options-1.69.0-13.fc32.aarch64.rpm
-rwxr-xr-x. 1 root root 296658 Jan 3 09:36 boost-regex-1.69.0-13.fc32.aarch64.rpm
-rwxr-xr-x. 1 root root 173104 Jan 3 09:36 boost-serialization-1.53.0-27.el7.x86_64.rpm
-rwxr-xr-x. 1 root root 40532 Jan 3 09:36 boost-system-1.53.0-27.el7.x86_64.rpm
-rwxr-xr-x. 1 root root 58712 Jan 3 09:36 boost-thread-1.53.0-27.el7.x86_64.rpm
-rwxr-xr-x. 1 root root 43584 Jan 3 09:36 boost-timer-1.53.0-27.el7.x86_64.rpm
-rwxr-xr-x. 1 root root 583524 Jan 3 09:36 edb-as10-server-libs-10.7.15-1.rhel7.x86_64.rpm
-rwxr-xr-x. 1 root root 621960 Jan 3 09:36 edb-bart-2.3.0-1.rhel7.x86_64.rpm
-rwxr-xr-x. 1 root root 7280 Jan 3 09:36 edb-pem-7.12.0-2.rhel7.x86_64.rpm
-rwxr-xr-x. 1 root root 925804 Jan 3 09:36 edb-pem-agent-7.12.0-2.rhel7.x86_64.rpm
-rwxr-xr-x. 1 root root 10775 Jan 3 09:36 libboost_atomic1.53.0-1.53.0-1.mga3.i586.rpm
-rwxr-xr-x. 1 root root 7912 Jan 3 09:36 libboost_atomic-devel-1.71.0-1.1.noarch.rpm
-rwxr-xr-x. 1 root root 105082 Jan 3 09:36 libboost_program_options1.42.0-1.42.0-3.2mdv2010.1.i586.rpm
-rwxr-xr-x. 1 root root 7824 Jan 3 09:36 libboost_regex-devel-1.71.0-1.1.noarch.rpm
-rwxr-xr-x. 1 root root 227824 Jan 3 09:36 libcurl-7.29.0-54.el7.x86_64.rpm
-rwxr-xr-x. 1 root root 242332 Jan 3 09:36 libmemcached-1.0.16-5.el7.x86_64.rpm
-rwxr-xr-x. 1 root root 268872 Jan 3 09:36 libsnmp0-4.2.3-16mdk.i586.rpm
-rwxr-xr-x. 1 root root 131987606 Jan 3 09:36 postgresql-10.11-3-linux-x64.run
-rwxr-xr-x. 1 root root 8520326 Jan 3 09:36 sqlprofiler-pg-10-7.12.0-1-linux-x64.run
[root@SGATRPRDOTH04 PEM]#
[root@SGATRPRDOTH04 PEM]#
[root@SGATRPRDOTH04 PEM]#
[root@SGATRPRDOTH04 PEM]# cd
[root@SGATRPRDOTH04 ~]#
[root@SGATRPRDOTH04 ~]# yum install --downloadonly --downloaddir=/PEM/ edb-pem-server
Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos, subscription-manager
This system is receiving updates from RHN Classic or Red Hat Satellite.
No package edb-pem-server available.
Error: Nothing to do
[root@SGATRPRDOTH04 ~]#
[root@SGATRPRDOTH04 ~]#

 

 

2.SEcond tried as per EDB requested.that also not working

root@SGATRPRDOTH04 ~]# cd /PEM/
[root@SGATRPRDOTH04 PEM]# rpm -ivh edb-repo-latest.noarch.rpm
warning: edb-repo-latest.noarch.rpm: Header V4 RSA/SHA1 Signature, key ID 7e30651c: NOKEY
Preparing... ################################# [100%]
Updating / installing...
1:edb-repo-20-1 ################################# [100%]
[root@SGATRPRDOTH04 PEM]#
[root@SGATRPRDOTH04 PEM]#
[root@SGATRPRDOTH04 PEM]#
[root@SGATRPRDOTH04 PEM]# cat /etc/yum.repos.d/edb.repo
[edb]
name=EnterpriseDB RPMs $releasever - $basearch
baseurl=https://aviva-asia:6124de384b6aa7601e7f196d40b08de5@yum.enterprisedb.com/edb/redhat/rhel-$releasever-$basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/ENTERPRISEDB-GPG-KEY

[edb-testing]
name=EnterpriseDB Testing - Not For Production $releasever - $basearch
baseurl=https://aviva-asia:6124de384b6aa7601e7f196d40b08de5@yum.enterprisedb.com/edb-testing/redhat/rhel-$releasever-$basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/ENTERPRISEDB-GPG-KEY

[root@SGATRPRDOTH04 PEM]#
[root@SGATRPRDOTH04 PEM]# yum install --downloadonly --downloaddir=/PEM/ edb-pem-server
Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos, subscription-manager
This system is receiving updates from RHN Classic or Red Hat Satellite.
https://aviva-asia:6124de384b6aa7601e7f196d40b08de5@yum.enterprisedb.com/edb/redhat/rhel-7Server-x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed connect to yum.enterprisedb.com:443; Connection refused"
Trying other mirror.
https://aviva-asia:6124de384b6aa7601e7f196d40b08de5@yum.enterprisedb.com/edb/redhat/rhel-7Server-x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed connect to yum.enterprisedb.com:443; Connection refused"
Trying other mirror.
https://aviva-asia:6124de384b6aa7601e7f196d40b08de5@yum.enterprisedb.com/edb/redhat/rhel-7Server-x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed connect to yum.enterprisedb.com:443; Connection refused"
Trying other mirror.
https://aviva-asia:6124de384b6aa7601e7f196d40b08de5@yum.enterprisedb.com/edb/redhat/rhel-7Server-x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed connect to yum.enterprisedb.com:443; Connection refused"
Trying other mirror.
https://aviva-asia:6124de384b6aa7601e7f196d40b08de5@yum.enterprisedb.com/edb/redhat/rhel-7Server-x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed connect to yum.enterprisedb.com:443; Connection refused"
Trying other mirror.
https://aviva-asia:6124de384b6aa7601e7f196d40b08de5@yum.enterprisedb.com/edb/redhat/rhel-7Server-x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed connect to yum.enterprisedb.com:443; Connection refused"
Trying other mirror.
https://aviva-asia:6124de384b6aa7601e7f196d40b08de5@yum.enterprisedb.com/edb/redhat/rhel-7Server-x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed connect to yum.enterprisedb.com:443; Connection refused"
Trying other mirror.
https://aviva-asia:6124de384b6aa7601e7f196d40b08de5@yum.enterprisedb.com/edb/redhat/rhel-7Server-x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed connect to yum.enterprisedb.com:443; Connection refused"
Trying other mirror.
https://aviva-asia:6124de384b6aa7601e7f196d40b08de5@yum.enterprisedb.com/edb/redhat/rhel-7Server-x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed connect to yum.enterprisedb.com:443; Connection refused"
Trying other mirror.
https://aviva-asia:6124de384b6aa7601e7f196d40b08de5@yum.enterprisedb.com/edb/redhat/rhel-7Server-x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed connect to yum.enterprisedb.com:443; Connection refused"
Trying other mirror.


One of the configured repositories failed (EnterpriseDB RPMs 7Server - x86_64),
and yum doesn't have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work "fix" this:

1. Contact the upstream for the repository and get them to fix the problem.

2. Reconfigure the baseurl/etc. for the repository, to point to a working
upstream. This is most often useful if you are using a newer
distribution release than is supported by the repository (and the
packages for the previous distribution release still work).

3. Run the command with the repository temporarily disabled
yum --disablerepo=edb ...

4. Disable the repository permanently, so yum won't use it by default. Yum
will then just ignore the repository until you permanently enable it
again or use --enablerepo for temporary usage:

yum-config-manager --disable edb
or
subscription-manager repos --disable=edb

5. Configure the failing repository to be skipped, if it is unavailable.
Note that yum will try to contact the repo. when it runs most commands,
so will have to try and fail each time (and thus. yum will be be much
slower). If it is a very temporary problem though, this is often a nice
compromise:

yum-config-manager --save --setopt=edb.skip_if_unavailable=true

failure: repodata/repomd.xml from edb: [Errno 256] No more mirrors to try.
https://aviva-asia:6124de384b6aa7601e7f196d40b08de5@yum.enterprisedb.com/edb/redhat/rhel-7Server-x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed connect to yum.enterprisedb.com:443; Connection refused"
https://aviva-asia:6124de384b6aa7601e7f196d40b08de5@yum.enterprisedb.com/edb/redhat/rhel-7Server-x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed connect to yum.enterprisedb.com:443; Connection refused"
https://aviva-asia:6124de384b6aa7601e7f196d40b08de5@yum.enterprisedb.com/edb/redhat/rhel-7Server-x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed connect to yum.enterprisedb.com:443; Connection refused"
https://aviva-asia:6124de384b6aa7601e7f196d40b08de5@yum.enterprisedb.com/edb/redhat/rhel-7Server-x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed connect to yum.enterprisedb.com:443; Connection refused"
https://aviva-asia:6124de384b6aa7601e7f196d40b08de5@yum.enterprisedb.com/edb/redhat/rhel-7Server-x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed connect to yum.enterprisedb.com:443; Connection refused"
https://aviva-asia:6124de384b6aa7601e7f196d40b08de5@yum.enterprisedb.com/edb/redhat/rhel-7Server-x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed connect to yum.enterprisedb.com:443; Connection refused"
https://aviva-asia:6124de384b6aa7601e7f196d40b08de5@yum.enterprisedb.com/edb/redhat/rhel-7Server-x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed connect to yum.enterprisedb.com:443; Connection refused"
https://aviva-asia:6124de384b6aa7601e7f196d40b08de5@yum.enterprisedb.com/edb/redhat/rhel-7Server-x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed connect to yum.enterprisedb.com:443; Connection refused"
https://aviva-asia:6124de384b6aa7601e7f196d40b08de5@yum.enterprisedb.com/edb/redhat/rhel-7Server-x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed connect to yum.enterprisedb.com:443; Connection refused"
https://aviva-asia:6124de384b6aa7601e7f196d40b08de5@yum.enterprisedb.com/edb/redhat/rhel-7Server-x86_64/repodata/repomd.xml: [Errno 14] curl#7 - "Failed connect to yum.enterprisedb.com:443; Connection refused"

Archived Discussions


Effective March 31st, we will no longer engage on PostgresRocks.


How to engage with us further?


  • Thought Leadership: EDB Blogs

  • Tips and Tricks: Postgres Tutorials

  • Customer Support: Create a Case Please note: Only customers with an active EDB support subscription and support portal authorization can create support ticket

  • Engage on Stackoverflow While engaging on Stackoverflow tag the question with EDB or EnterpriseDB.

3 REPLIES 3
Highlighted
EDB Team Member

Re: PEM 7.12 RPM installation Failed due to dependencies.

Hello , 

 

Hope you are doing good. 

 

On Analsing logs, It seems you are unable to reach EDB YUM Server. Might be wrong credentails. 

 

Could you please check yum credentials which you are using , and Kindly do not post any credentails on Postgres Rocks.

 

If you need any further assistane, Please drop a mail to support@enterprisedb.com 

 

Please let me know if you need anymore details. 

 

Regards

Siva.

Highlighted
Silver Adventurer

Re: PEM 7.12 RPM installation Failed due to dependencies.

Hi ,

       Can you please share the dependent RPM's in single Zip file.

 

Thanks!!!

FYI

[root@SGATRPRDOTH04 PEM]# rpm -ivh edb-pem-7.12.0-2.rhel7.x86_64.rpm
error: Failed dependencies:
edb-pem-server = 7.12.0-2.rhel7 is needed by edb-pem-7.12.0-2.rhel7.x86_64
edb-pem-docs = 7.12.0-2.rhel7 is needed by edb-pem-7.12.0-2.rhel7.x86_64
edb-pem-agent = 7.12.0-2.rhel7 is needed by edb-pem-7.12.0-2.rhel7.x86_64
[root@SGATRPRDOTH04 PEM]# rpm -ivh edb-pem-agent-7.12.0-2.rhel7.x86_64.rpm
error: Failed dependencies:
libcurl-pem >= 7.61.1 is needed by edb-pem-agent-7.12.0-2.rhel7.x86_64
snmp++ >= 3.3.8 is needed by edb-pem-agent-7.12.0-2.rhel7.x86_64
boost-regex is needed by edb-pem-agent-7.12.0-2.rhel7.x86_64
boost-atomic is needed by edb-pem-agent-7.12.0-2.rhel7.x86_64
boost-program-options is needed by edb-pem-agent-7.12.0-2.rhel7.x86_64
libboost_atomic-mt.so.1.53.0()(64bit) is needed by edb-pem-agent-7.12.0-2.rhel7.x86_64
libboost_program_options.so.1.53.0()(64bit) is needed by edb-pem-agent-7.12.0-2.rhel7.x86_64
libboost_regex.so.1.53.0()(64bit) is needed by edb-pem-agent-7.12.0-2.rhel7.x86_64
libsnmp++.so.33()(64bit) is needed by edb-pem-agent-7.12.0-2.rhel7.x86_64
[root@SGATRPRDOTH04 PEM]#

Highlighted
EDB Team Member

Re: PEM 7.12 RPM installation Failed due to dependencies.

Hi  Din2pg,

 

We had gone through your request on the availability of dependencies for the PEM 7.12.

Your recommend of getting in touch with Support Team.

EDB Support Team would be able to assist you with having the dependent RPM's for the PEM 7.12 installation.

© 2019 EnterpriseDB Corporation. All rights reserved.   |   Privacy Policy   |  Terms of Use   |   Trademarks