cancel
Showing results for 
Search instead for 
Did you mean: 

EFM-2.1 Not Started after applied patch

SOLVED
EDB Team Member

Re: EFM-2.1 Not Started after applied patch

Well, you found your problem. The 'efm' user can't run sudo any more on this system.

 

It would be good to know what you've done on the system to change the default behavior (the efm user does not install with a password and can run sudo normally by the sudoers conf file). I think you need to reach out to your support person for more help, but at least now we know what the issue is.

 

Cheers,

Bobby

 

EDB Team Member

Re: EFM-2.1 Not Started after applied patch


@bbissett wrote:

Well, you found your problem. The 'efm' user can't run sudo any more on this system.

 

It would be good to know what you've done on the system to change the default behavior (the efm user does not install with a password and can run sudo normally by the sudoers conf file). I think you need to reach out to your support person for more help, but at least now we know what the issue is.


 

For what it's worth, starting with EFM 3.0 you can run failover manager as the database user and not rely on sudo at all. There's a little more setup involved, but it all works. More info:

https://postgresrocks.enterprisedb.com/t5/Postgres-Gems/Running-EDB-Postgres-Failover-Manager-Withou...

 

Cheers,

Bobby

 

Tags (2)
Level 2 Adventurer

Re: EFM-2.1 Not Started after applied patch

Thanks,

          but testing server again its happend the same issue..not only this postgresql..some other database like mongoDB also..same...what actully i need to do..in my sudo part...

My efm user expired few months back..i suggest to reset of unix os user efm password.but my GM told last month also we did in patch..no issue happend in prod and uat...why we reset the password...

 

Please suggest what i do in my sudo part..or anything someother part's?

Highlighted
EDB Team Member

Re: EFM-2.1 Not Started after applied patch


@Diny2019 wrote:

          but testing server again its happend the same issue..not only this postgresql..some other database like mongoDB also..same...what actully i need to do..in my sudo part...

My efm user expired few months back..i suggest to reset of unix os user efm password.but my GM told last month also we did in patch..no issue happend in prod and uat...why we reset the password...

 

Please suggest what i do in my sudo part..or anything someother part's?


 

I don't know offhand what the solution is. It depends on how your system has sudo set up. My guess is you've run into this, which will affect anything that needs to run sudo:

 

https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/7.6_release_notes/new_...

 

When we tried upgrading the OS we didn't see the problem -- something your the PAM configuration is affected.

 

FWIW, when trying to debug it, you don't actually need to run efm. As the efm user, run something like:

 

sudo <efminstall>/bin/efm_root_functions readnodes <clustername>

 

Cheers,

Bobby